Week 45-46 (2021)

Release notes:

  • [APD-1080] We have extended the logging for Database connections. You will now be able to view the sent query and the response from the database system
  • [APD-1503] A new menu has been implemented, allowing for a cleaner look. Besides that, the header and footer have been removed
  • [APD-1762] Before it was only possible to filter on a "Disabled" status of a configuration. We have changed this to be more flexible. You can now filter on the status "Enabled" and "Disabled"
  • [APD-1763] Automated updates for UAT environments have been enabled. This will result in the latest version of Alumio being published to your UAT environment every 2 weeks (unless opted-out)
  • [APD-1784] We have implemented a cXML encoder and decoder. This new feature can be found in: Value mapper > (De)Serializer > cXML
  • [APD-1787] You can now save a configuration with your keyboard shortcut: CTRL-S or CMD-S, depending on your OS
  • [APD-1794] Support added for Amazon S3 Authentication and Filesystem
  • [APD-1814] Solved a bug where switching prototypes would not reset the values
  • [APD-1819] When logged into a UAT environment, you will now see an orange/red bar at the bottom giving an indication that you're on UAT
  • [APD-1824] It's now possible to split large arrays into smaller arrays. This can be done via: Data transformer > Value mapper > List: Split into chunks
  • [APD-1827] We have unified the styling of notification popups within Alumio, moving them all towards a single design
  • [APD-1828] Solved an issue where you would be logged out of Alumio when performing a /401 request in an HTTP Transformer
  • [APD-1837] Solved an issue where moving keys with only digits, the key value would give a wrong result back. For instance, the value "00001" would get transformed into "1"
  • [APD-1839] It's now possible to collapse certain areas within the Transformer Tester
  • [APD-1840] Solved an issue where the task subscriber would break for tasks without an "Updated at" value
  • [APD-1842] Solved a bug where the Scheduler would stop working for any scheduled job if one of the scheduled jobs was set to disabled. This problem also occurred with an incorrect cron expression

2 people like this